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HVAC Room 
In this tutorial you will use the Heating Ventilation and Air Conditioning (HVAC) features to model a duct that heats and 

circulates air in two rooms. We will define a fire in one room to demonstrate how the HVAC network will distribute the 

smoke throughout the network.  

An HVAC system is described as a network of duct segments and nodes. Nodes can either connect two or more ducts 

(for example, a T connection of three ducts) or be an endpoint where an HVAC duct connects to the FDS computational 

domain or the infinite ambient void outside of the domain. The HVAC network consists of lines (ducts) and points 

(nodes). It is only necessary to draw the true geometry at vents where the HVAC system connects to the FDS domain. 

 

Figure 1. HVAC model. 

This tutorial demonstrates how to: 

• Create HVAC nodes and ducts. 

• Create an HVAC fan. 

• Define an HVAC surface on a vent. 

• Use devices to plot HVAC parameters. 

Throughout this example, the instructions will describe data input using menu dialogs. This is done for clarity and 

consistency. However, PyroSim provides both drawing tools and shortcut toolbars that can speed many of these tasks. 

The user is encouraged to experiment with these alternate approaches to model creation. 



 

 

 

Start a New Model 
To start a new model. 

1. On the File menu, click New. 

2. On the View menu, click Units and select SI to display values using the metric system. 

3. Save the model. On the File menu, click Save and choose a folder. Name the file hvac_room.psm. 

4. Click OK to save the model. 

Computational Mesh 
In this example we will use a 10 m x 10.25 m x 3 m mesh with 0.25 m cells. 

1. On the Model menu, click Edit Meshes. 

2. Click New. 

3. Click OK to create the new mesh. 

4. In the Min X box, type 0 and in the Max X box, type 10. 

5. In the Min Y box, type -5.125 and in the Max Y box, type 5.125. 

6. In the Min Z box, type 0.0 and in the Max Z box, type 3.0. 

7. In the X Cells box, type 40. 

8. In the Y Cells box, type 41. 

9. In the Z Cells box, type 12. 

10. Click OK to save changes and close the Edit Meshes dialog. 

11. On the toolbar, click Reset View to All Visible Objects. 

You will notice that in the Y direction, I arranged the mesh so that there are an odd number of cell divisions and made 

the mesh symmetric about the Y=0 plane. The reason for this is that we will use a wall to divide the mesh into two 

rooms. FDS “snaps” all geometry to the grid boundaries. I wanted the wall to be 0.25 m thick, so that is the reason for 

the extra Y cell. 

Create the Duct Enclosure 
Strictly speaking, we only need to define obstructions at the vent locations where the HVAC network connects to the 

FDS computational domain. However, in this model, we will represent the entire duct geometry, partly because it makes 

the final visualization more realistic. 

1. On the Model menu, click New Obstruction. 

2. In the ID box, type Duct Enclosure. 

3. Click Specify Color and then select the color of your choice (I used boring grey). 

4. Click the Geometry tab. 

5. In the Min X box, type 0 and in the Max X box, type 1. 

6. In the Min Y box, type -3 and in the Max Y box, type 3. 

7. In the Min Z box, type 2 and in the Max Z box, type 2.5. 

8. Click OK to create the obstruction. 

Create the Wall 
A wall will split the mesh into two rooms. 



 

 

 

1. On the Model menu, click New Obstruction. 

2. In the ID box, type Wall. 

3. Click the Geometry tab. 

4. In the Min X box, type 0 and in the Max X box, type 10. 

5. In the Min Y box, type -0.125 and in the Max Y box, type 0.125. 

6. In the Min Z box, type 0 and in the Max Z box, type 3. 

7. Click OK to create the obstruction. 

Create Vents 
In this model, vents are used at the end of HVAC duct segments to connect to the FDS computational domain. We will 

place the supply vents on the supply duct and the inlet vents on the wall. To create the supply vents: 

1. On the Model menu, click New Vent. 

2. In the ID box, type Right Supply Vent. 

3. In the Surface list, select HVAC.  

4. Click on the Geometry tab.  

5. Select the X Plane and type 1.0 in the box. 

6. In the Min Y box, type -3 and in the Max Y box, type -2.5. 

7. In the Min Z box, type 2.0 and in the Max Z box, type 2.5. 

8. Click OK and then click OK again to accept the conversion to an HVAC vent. 

Now we will copy the Right Supply Vent to make the Left Supply Vent. 

1. In the Navigation View, right-click the Right Supply Vent and click Copy/Move. 

2. Select Copy. 

3. In the Offset, in the Y box type 5.5. 

4. Click OK. 

5. In the Navigation View, right-click the copied vent and rename it Left Supply Vent. 

The return vents will be positioned on the wall. To create the Right Return Vent: 

1. On the Model menu, click New Vent. 

2. In the ID box, type Right Return Vent. 

3. In the Surface list, select HVAC.  

4. Click on the Geometry tab.  

5. Select the Y Plane and type -0.125 in the box.  

6. In the Min X box, type 8 and in the Max X box, type 9. 

7. In the Min Z box, type 2.25 and in the Max Z box, type 2.75. 

8. Click OK and then click OK again to accept the conversion to an HVAC vent. 

Now we will copy the Right Return Vent to make the Left Return Vent. 

1. In the Tree View, right-click the Right Return Vent and click Copy/Move. 

2. Select Copy. 

3. In the Offset, in the Y box type 0.25. 



 

 

 

4. Click OK. 

5. In the Navigation View, right-click the copied vent and rename it Left Return Vent. 

The last step is to add HVAC nodes at the vent locations. To do this: 

1. In the Navigation View, press the CTRL key and select the four vents we just made (Right Supply Vent, Left 

Supply Vent, Right Return Vent, Left Return Vent). 

2. Right-click on the selected vents, and click Add HVAC Nodes. 

3. Rename the numbered HVAC nodes with names that match the vents (for example, HVAC Right Supply Node). 

 

Figure 2. The duct obstruction and supply and return vents 

Figure 2 shows the duct obstruction and the supply and return vents. It is worth repeating that vents are required at the 

ends of the HVAC network to connect the HVAC calculations with the FDS computational domain. 

Create HVAC Network 
We now create the HVAC network. This is the network of ducts, nodes, and fan that are calculated by a separate module 

with the results then coupled to the FDS solution. As stated above, this coupling occurs at special HVAC vents. 

We now create the HVAC nodes. First, we will add an HVAC node at the junction of the two supply ducts.   

1. On the Model menu, click New HVAC Node. 

2. In the ID, type HVAC Supply Node Junction. 

3. Click the Geometry tab. 

4. In X box type 1, in Y box type 0, and in Z box type 2.25. 

5. Click OK. 



 

 

 

Now add an HVAC node at the junction of the two return ducts.   

1. On the Model menu, click New HVAC Node. 

2. In the ID, type HVAC Return Node Junction. 

3. Click the Geometry tab. 

4. In X box type 8.5, in Y box type 0, and in Z box type 2.5. 

5. Click OK. 

 

Figure 3: Top view showing the locations of the HVAC nodes. 

Now we create the HVAC fan. In this example, we will create one fan and only use it once, but this could be extended to 

using the same fan in many locations. To create the fan:  

1. On the Model menu, click Edit HVAC. 

2. Click New, select Type as FAN and in the Name box type Fan, 2 m^3/s. Click OK. 

3. For Fan Model, select Constant Flow and in the Volume Flow Rate box type 2. 

4. Click OK to close the Edit HVAC dialog. 

Now we define the HVAC ducts. These must connect HVAC nodes. First, we make the right supply duct. 

1. On the Model menu, click New HVAC Duct. 

2. In the ID, type HVAC Right Supply Duct. 

3. For Node 1 select HVAC Supply Node Junction and for Node 2 select HVAC Right Supply Node. 

4. Click OK to create the duct. 



 

 

 

 

Figure 4: Creating the first HVAC duct. 

Repeat for the left supply duct. 

1. On the Model menu, click New HVAC Duct. 

2. In the ID, type HVAC Left Supply Duct. 

3. For Node 1 select HVAC Supply Node Junction and for Node 2 select HVAC Left Supply Node. 

4. Click OK to create the duct. 

 

Repeat this process for both return ducts. 

Make the right return duct. 

1. On the Model menu, click New HVAC Duct. 

2. In the ID, type HVAC Right Return Duct. 

3. For Node 1 select HVAC Return Node Junction and for Node 2 select HVAC Right Return Node. 

4. Click OK to create the duct. 

Repeat for the left return duct. 

1. On the Model menu, click New HVAC Duct. 

2. In the ID, type HVAC Left Return Duct. 

3. For Node 1 select HVAC Return Node Junction and for Node 2 select HVAC Left Return Node. 

4. Click OK to create the duct. 



 

 

 

There are now four HVAC ducts in the model for both Supply and Return sides of the network. 

Finally, we define the duct that connects the supply and return center nodes. 

1. On the Model menu, click New HVAC Duct. 

2. In the ID, type HVAC Fan Duct. 

3. For Node 1 select HVAC Return Node Junction and for Node 2 select HVAC Supply Node Junction. 

4. Click the Flow Model tab and select the Flow Device as Fan (not Basic Fan).  In the Fan pulldown menu, select 

the previously created Fan, 2 m^3/s. 

5. The Flow Direction is from Node 1 to Node 2. 

6. Click OK. 

Note that for this fan that we created, there is the option to use controls to activate and deactivate. 

 

Figure 5: The HVAC network (labels have been turned off). 

HVAC Devices 
We use devices to plot HVAC quantities. Both duct and node quantities can be plotted, we will illustrate with one of 

each. First a device to plot the duct velocity. 

1. On the Devices menu, click New HVAC Duct Device. 

2. In the Name box type HVAC Velocity and in the Quantity menu select [HVAC Quantity]. This will open a Choose 

Quantity dialog. 

3. For the Quantity select Velocity of a Duct and in the HVAC Duct select HVAC Fan Duct.  

4. Click OK to close the Choose Quantity dialog and then OK again to close the HVAC Device dialog. 

Now a device to plot the return air temperature. 



 

 

 

1. On the Devices menu, click New HVAC Node Device. 

2. In the Name box type Right Return Temperature and in the Quantity menu select [HVAC Quantity]. This will 

open a Choose Quantity dialog. 

3. For the Quantity select Temperature of the Flow through a Node and in the HVAC Node select HVAC Right 

Return Node.  

4. Click OK to close the Choose Quantity dialog and then OK again to close the HVAC Device dialog. 

Slice Planes 
Slice planes can be used to display 2D contours in the PyroSim Results display. In this analysis, we will save velocity data 

for future plotting. To define the slice planes: 

1. On the Output menu, click 2D Slices. 

2. Fill the table by entering the values in Table 1. You can click on the row number to select entire rows to copy and 

paste, speeding the entry. 

3. Click OK to close the Animated Planar Slices dialog. 

Click the Show Slices tool to enable/disable display of the slices. 

Table 1: Slice plane data 

XYZ Plane Plane Value (m) Gas Phase Quantity Use Vector? Cell Centered? 

Z 2.25 Velocity YES NO 

X 8.5 Velocity YES NO 

Y -2.75 Velocity YES NO 

Y 2.75 Velocity YES NO 

 

Specify Simulation Properties 
1. On the Analysis menu, click Simulation Parameters. 

2. In the End Time box, type 20. 

3. Click OK. 

Save and Run the Simulation 
1. On the File menu, click Save. 

2. On the FDS menu, click Run FDS. 

3. The FDS Simulation dialog will appear and display the progress of the simulation. 

4. When the simulation is complete, PyroSim Results will launch automatically and display a 3D image of the 

model. 

View Slice Data 
1. In the tree click to expand 2D Slices > VELOCITY. 

2. Double click Y = -2.625 to show the velocity slice at that location. 

3. Double click Y = 2.875 to show the velocity slice at that location. 

4. In the tree click to expand 2D Slice Vectors > VELOCITY. 

5. Double click Z = 2.250 to show the vector slice at that location. 



 

 

 

The plot of the velocity contours is shown in Figure 6. Notice the flow into the return vents. 

 

Figure 6: Velocities in model, plotted using a combination of slice and vector slice planes. 

On the toolbar, select Plot Device Results. The duct diameter is 0.3048 m, so the expected velocity of flow in the duct 

for a volumetric flow rate of 2 m3/s is 27.4 m/s. 

 

Figure 7: Velocity of flow in duct. 



 

 

 

Add Fire and Smoke to the Simulation 
To demonstrate how the HVAC network can distribute smoke throughout the model, we will add a fire in one room and 

watch it appear in the second room. 

Save the Fire Model 
To save the fire model: 

1. On the File menu, click Save As. 

2. Name the file hvac_room_fire.psm. 

3. Click OK to save the model. 

Reaction 
Define the reaction for this simulation. 

1. On the Model menu, click Edit Reactions. 

2. Click the Add From Library button, select the POLYURETHANE reaction, and move it to the Current Model. Click 

Close.  

3. Click OK to close the dialog. 

Create the Fire Surface 
In this example, we define a burner (fire) surface that releases heat at a rate of 500 kW/m2. 

1. On the Model menu, click Edit Surfaces. 

2. Click New. 

3. In the Surface Name box, type Fire. 

4. In the Surface Type list, select Burner. 

5. Click OK to create the burner surface. 

6. In the Heat Release tab of the Fire surface, select Heat Release Rate Per Area (HRRPUA) and in the box type 

500. 

7. Click OK to save changes and close the Edit Surfaces dialog. 

Create the Fire 
Now we define the fire location in our model. 

1. On the Model menu, click New Vent. 

2. In the ID box, type Fire Vent. 

3. In the Surface list, select Fire.  

4. Click on the Geometry tab. In the Plane list, select Z and in the location box type 0.0. 

5. In the Min X box, type 6 and in the Max X box, type 7. 

6. In the Min Y box, type –3 and in the Max Y box, type -2. 

7. Click OK to create the new burner vent. 



 

 

 

Add a Vent to Represent an Open Door 
Now we will define an open vent that will represent an open door. This will provide both a fresh air supply for the fire 

and an opening that will allow the heated air a place to vent to atmosphere. If we did not do this, the average air 

pressure in the rooms would increase as the air is heated by the fire. 

1. On the Model menu, click New Vent. 

2. In the ID box, type Door. 

3. In the Surface list, select OPEN. This is a special surface always available in FDS. 

4. Click on the Geometry tab. In the Plane list, select X and in the location box type 10. 

5. In the Min Y box, type 1 and in the Max Y box, type 2. 

6. In the Min Z box, type 0 and in the Max Z box, type 2.5. 

7. Click OK to create the open door. 

Save and Run the Simulation 
1. On the File menu, click Save. 

2. On the FDS menu, click Run FDS. 

3. Click Ignore to dismiss the warning about the model not being connected to an ambient pressure boundary 

condition. Sealed compartments typically indicate a modeling oversight, but for this demonstration it is safe to 

ignore the warning. 

4. The FDS Simulation dialog will appear and display the progress of the simulation. 

5. When the simulation is complete, PyroSim Results will launch automatically and display a 3D image of the 

model. 

View Smoke and Fire 
1. In the PyroSim Results window, double click 3D Smoke to load the HRRPUV and Soot Mass Fraction datasets. 

The plot of the smoke is shown in Figure 8. 



 

 

 

 

Figure 8: Smoke distribution in the model. The smoke in the room with a fire is drawn into the return vent and then 
mixes and distributed to the second room. 

On the toolbar, select Plot Device Results and then select Right Return T, Figure 9. 

 

Figure 9: Temperature of air in return duct in room with fire. 
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